Polytech-soft.com

ПК журнал
1 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Форматирование текста в ячейке excel

Форматирование ячеек в Excel: настраиваем текст

В посте «Форматы данных» мы уже разобрали, как выбрать нужный формат для правильного отображения содержимого ячейки. В этой статье я расскажу, как еще можно изменить текст в Экселе, чтобы получать хорошо читаемые таблицы.

Для форматирования в Эксель предусмотрены следующие пути:

  1. Через команды на ленте Главная – Шрифт и Главная – Выравнивание
  2. С помощью контекстной мини-панели
  3. В диалоговом окне «Формат ячеек»

Как изменить шрифт Excel

Когда вы создаёте новый лист, шрифт в ячейках по умолчанию – Calibri (начиная с MS Office 2007) размером 11 пунктов. Напомню, 72 пункта – это один дюйм. В старых версиях по умолчанию установлен шрифт Arial, 10 пунктов.

Чтобы изменить вид шрифта, или его размер, выделите ячейки и выберите из списка на ленте: Главная – Шрифт . В списке легко сделать выбор, ведь каждое название начертано своим шрифтом.

Выбор шрифта на ленте Excel 2013

Еще один способ – выделить нужный диапазон и кликнуть правой кнопкой мыши. Возле контекстного меню появится мини-панель с такими же раскрывающимися списками выбора шрифта и размера.

Мини-панель Эксель

Откройте окно Формат ячеек любым способом, например, нажмите Ctrl+1 . В окне перейдите на вкладку Шрифт , выберите вид и размер шрифта в соответствующих полях.

Изменение шрифта в окне «Формат ячеек»

Старайтесь использовать стандартные шрифты Windows, например, Calibri, Arial, Times New Roman, Verdana, Century Gothic и др. Если используемый вами шрифт не установлен на других компьютерах, файл Эксель на них отобразится неправильно. Хотя, никогда не поздно установить нужный шрифт!

Как выбрать способы начертания Excel

Иногда нужно поставить какие-то акценты в содержимом ячейки. Например, сделать его полужирным, наклонным, подчеркнуть и др. Чтобы применить такой формат ко всей ячейке – выделите всю клетку. Если хотите форматировать только часть текста – сделайте двойной клик внутри ячейки и мышью выделите ту часть, которую собираетесь форматировать.

Теперь, чтобы внести изменения, воспользуйтесь одним из способов:

  1. Используйте горячие клавиши:
    • Ctrl+B – сделать полужирным
    • Ctrl+I – текст курсивом
    • Ctrl+U – подчеркнуть
    • Ctrl+5 – перечеркнуть
    • Ctrl+= – подстрочный формат (например, чтобы сделать индекс)
    • Ctrl+Shift++ – надстрочный (сделать степень в Эксель)
  2. Почти тот же набор команд можно найти на ленте в блоке Главная – Шрифт
    Настройка начертания с на ленте Эксель
  3. Откройте окно Формат ячеек и выберите нужные параметры в блоках Начертание и Видоизменение . В окне сразу будет показан образец отформатированного текста

Начертание текста в окне «Формат ячеек»

Выравнивание текста в ячейках

Выравнивание текста – это параметр, указывающий каким образом текст будет располагаться в клетке. Указать параметры выравнивания можно такими способами:

  • На ленте в блоке: Главная – выравнивание . Кнопки-миниатюры красноречиво показывают, как будет выровнен текст, можно выбрать параметры горизонтального и вертикального выравнивания одновременно
    Выравнивание текста Эксель с помощью ленточных команд
  • В окне Формат ячеек на вкладке Выравнивание . В блоке Выравнивание выберите отдельно значения «по горизонтали» и «по вертикали».
    Выравнивание с помощью окна «Формат ячеек»

В Excel доступны такие виды горизонтального выравнивания:

  • По значению – выравнивание устанавливается автоматически, в зависимости от типа данных. Текст выравнивается по левому краю, цифры – по правому, логические значения и ошибки – по центру
  • По левому краю (отступ) – текст примыкает к левой границе ячейки, слева добавляется отступ (если задан)
  • По центру – текст располагается в центре ячейки
  • По правому краю (отступ) – текст примыкает к правой границе ячейки, справа добавляется отступ (если задан)
  • С заполнением – повторяет содержимое ячейки, чтобы заполнить её полностью
  • По ширине – выравнивает текст и по левому краю и по правому. В этом формате большие тексты читаются лучше. Неполная строка — по значению
  • По центру выделения – подходит, когда нужно, чтобы текст отображался в центре какого-то диапазона. Например, чтобы название таблицы располагалось строго по центру, выделите все столбцы таблицы и примените это выравнивание
  • Распределенное (отступ) – аналогично «По ширине», неполная строка – по центру

Примеры использования выравнивания по горизонтали

Вертикальное выравнивание текста можно выбрать из таких вариантов:

  • По верхнему краю – текст примыкает к верхней границе ячейки
  • По центру – содержимое располагается в середине клетки
  • По нижнему краю – текст примыкает к нижней границе ячейки
  • По высоте – данные, записанные в несколько строк, распределяются по вертикали так, чтобы заполнить всю ячейку
  • Распределенное – аналогично «По высоте»

Примеры выравнивания по вертикали в ячейках Excel

Автоформатирование текста в Эксель

Если вы записываете в ячейки длинный текст и есть вероятность, что он не вместится в клетку и не будет отображён полностью, можно применить 2 способа для автоматического отображения всего текста:

  1. Применить перенос по словам. Выделите ячейки для форматирования и выполните Главная – Выравнивание – Перенести текст . Другой способ сделать то же самое – в окне Формат ячеек на листе Выравнивание установите галочку Переносить по словам . Когда эта функция включена, программа сама расставляет переносы и увеличивает высоту строки, чтобы данные влезали в ячейки по ширине
  2. Используйте автоподбор по ширине. Если включить этот параметр, текст будет сужаться так, чтобы влезть в ячейку полностью. Для этого, установите галку в окне Формат ячеек — Выравнивание – Автоподбор ширины .
Читать еще:  Конвертировать видео в другой формат бесплатно

Как объединить ячейки в Excel

Иногда, при оформлении таблицы, нужно слить несколько ячеек Excel в одну. Лучше всего это сделать с помощью ленточной команды: Главная – Выравнивание – Объединить и поместить в центре . Применение этой команды приведёт к слиянию всех выделенных смежных ячеек, а в получившейся большой клетке останется содержимое первой ячейки диапазона. Остальная информация из массива исчезнет. Данные будут выровнены по центру.

Параметры этой комбинированной команды можно открыть, щёлкнув на стрелке «вниз» справа от названия кнопки.

Вы сможете выполнить такие дополнительные команды:

  • Объединить по строкам – сливаются только столбцы в каждой строчке выделенного диапазона. Это существенно облегчает структурирование таблиц.
  • Объединить ячейки – сливает все выделенные ячейки в одну, но не выравнивает текст по центру
  • Отменить объединение ячеек – название само говорит за себя, объединённые ячейки снова становятся отдельными клетками листа.

Инструменты объединения – это ключ к созданию структурированных данных. Освойте их использование как можно лучше, чтобы в будущем было легче управляться со сложными таблицами.

Изменение ориентации и направления текста

Эти два инструмента очень похожи друг на друга, их часто путают. Вы будете регулярно применять их в работе, поэтому хорошо усвойте различия. Для примера я привожу рисунок. В столбце А я изменил ориентацию текста, а в столбце В — направление. Разница очевидна.

Ориентация и направление текста в Excel

Чтобы изменить эти два параметра воспользуйтесь ленточной командой Главная – Выравнивание – Ориентация . Чтобы выставить произвольный угол ориентации текста, укажите его в окне Формат ячеек — Выравнивание – Ориентация .

Вот и всё о форматировании текста. Надеюсь, перечисленные возможности помогут вам в структурировании данных и достижении максимальной эстетичности рабочего листа.

В следующем посте я расскажу как правильно делать заливку цветом, разукрашивать текст и еще много интересного. До встречи!

Условное форматирование по части текста в ячейке Excel

У нас имеется данные для анализа производимой продукции. Нам нужно автоматически выделить все изделия, которые были выпущены в 2006 году. К сожалению, в таблице недостает еще одного столбца содержащего значения года производства каждого изделия. Но видно, что в фрагменте идентификатора (ID) изделия указывается год производства. В таком случае нам нужно выполнить поиск по части текста в Excel. А потом мы будем использовать условное форматирование с текстовыми функциями в формуле. Благодаря этому молниеносно реализуем решение задачи.

Пример таблицы производимой продукции:

Чтобы на основе идентификатора выделить изделия 2006-го года выпуска выполним шаги следующих действий:

  1. Выделите диапазон ячеек A2:A10 и выберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Создать правило».
  2. Выберите: «Использовать формулу для определения форматируемых ячеек».
  3. Чтобы выполнить поиск части текста в ячейке Excel, введите формулу: =ПСТР(A2;5;4)=»2006″
  4. Нажмите на кнопку «Формат», чтобы задать красный цвет заливки для ячейки. И нажмите ОК на всех открытых окнах.

Экспонированные цветом изделия 2006-го года выпуска:

Далее разберем принцип действия формулы и ее модификации схожими текстовыми функциями.

Функция ПСТР и ее пример в использования условном форматировании

Чтобы легко понять, как удалось экспонировать цветом определенные значения с помощью условного форматирования разберем этапы действий в двух словах. Сначала мы извлекаем часть текста, а потом сравниваем его с требуемым значением. Но как из ячейки извлечь часть текста в Excel? Обратим внимание на функцию =ПСТР() в формуле правила. Данная функция возвращает часть строки, взятой с каждой ячейки столбца A, что указано в первом аргументе. Ссылка в первом аргументе должна быть относительной, так как формула применяется к каждой ячейке столбца A. Во втором аргументе функции указывается номер символа исходного текста, с которого должен начаться отрезок строки. В третьем аргументе указывается количество символов, которые нужно взять после определенного (во втором аргументе) символа исходного текста. В результате функция =ПСТР() возвращает только часть текста длинной 4 символа взятого начиная с 5-ой буквы в каждой ячейки из столбца А. Это «2005» или «2006». После функции стоит оператор сравнения к значению строки «2006». Если ячейка содержит такую часть текста значит ей будет присвоен новый формат.

Читать еще:  Как решать примеры в excel

Аналогичным способом можно использовать и другие текстовые функции в условном форматировании. Например, с помощью функции =ПРАВСИМВ() мы можем экспонировать цветом определенную группу товаров из партии C. Для этого нужно использовать формулу:

Здесь все просто функция позволяет выбрать часть текста из ячейки Excel, начиная с правой стороны исходного текста. Количество необходимых символов указано во втором аргументе функции ПРАВСИМВ. После чего все что возвращает функция сравнивается с значением строки «C».

Во всех выше описанных примерах очень легко применять текстовые функции в условном форматировании так как длина строк в исходных данных одинаковая. Но что, если у нас в исходных данных разного типа индикаторы с разной длинной символов, а нам все еще нужно выделять 2006-й год или группу «C».

В решении данной задачи нам поможет дополнительная текстовая функция в формуле =НАЙТИ(). В первом случаи формула будет выглядеть так:

Для удобного выделения идентификаторов с разной длинной текстовой строки товаров из группы «C» используем такую формулу:

Функция =НАЙТИ() выполняет поиск фрагмента текста в ячейке Excel. Потом возвращает номер символа, в котором был найдет текст, который задан в первом аргументе. Во втором аргументе указываем где искать текст. А третий аргумент – это номер позиции с какого символа вести поиск в исходном тексте. Третий аргумент позволяет нам смещаться по строке. Например, если в идентификаторе 2 раза используется символ «C». В таком случае третий аргумент пользователь задает в зависимости от ситуации.

Так как функция возвращает нужное число мы прекрасно используем ее в качестве аргументов для других функций (ПСТР и ПРАВСИМВ).

Работа со стилями форматирования ячеек Excel

Зачем нужны именованные стили

Идея именованных стилей заключается в следующем:

  1. Можно создать собственный набор стилей для форматирования, например, заголовков, итогов, обычного текста. А после применять готовые стили на другие ячейки не тратя время на воспроизведение точно такого же формата.
  2. Если изменить формат стиля, то все ячейки, к котором применен данный стиль будут автоматически отформатированы. Таким образом, можно быстро пересматривать любой формат и не тратить время на форматирование ячеек по отдельности.

Стили Excel позволяют отформатировать следующие атрибуты:

  • числовой формат (например, число, короткий формат даты, формат телефонного номера и т.п.);
  • выравнивание (по вертикали и горизонтали);
  • шрифт (название, размер, цвет и пр.);
  • граница (тип линии, цвет границы);
  • заливка (цвет фона, узор);
  • защита (защищаемая ячейка, скрытие формул).

Применение стилей к ячейкам листа

В Excel изначально установлено множество встроенных стилей. Найти их можно в меню Стили ячеек, которая расположена на вкладке Главная -> Стили.

Откроется галерея стилей (рисунок справа).

Чтобы применить стиль к выделенной ячейке или диапазону, необходимо щелкнуть левой кнопкой мыши по нужному стилю. Имеется также очень удобная возможность предварительного просмотра: при наведении курсора на стиль, Вы будете видеть как меняется стиль ячейки.

После применения стиля из галереи можно будет накладывать дополнительное форматирование на ячейки.

Создание новых стилей

Если встроенных стилей Excel не достаточно, то можно создать собственные стили. Это достаточно просто сделать:

  1. Выберите любую ячейку и отформатируйте ее обычным способом так как вам нравится. Форматирование этой ячейки в дальнейшим мы сохраним как именованный стиль. Вы можете использовать любое доступное форматирование из диалогового окна Форматирование ячеек.
  2. Перейдите на вкладку Главная ->Стили ячеек и выберите команду Создать стиль ячейки. Откроется диалоговое окно Стиль.
  3. Выберите Имя стиля, которое будет в дальнейшем будете использовать.
  4. Выберите опции, которые будут применяться к выбранному стилю (по умолчанию отмечены все опции). Если нет необходимости в какой то опции, например вы не хотите изменять шрифт ячейки — то снимите выбор.
  5. Нажмите кнопку OK.

В результате в активную книгу будет добавлен новый пользовательский стиль, который будет доступен в меню Стили ячеек.

Изменение существующих стилей

Вы можете изменить форматирование существующего стиля. При этом все ячейки, к которым применен данный стиль также изменят форматирование. Чтобы изменить стиль необходимо:

  1. Перейти на вкладку Главная ->Стили ячеек.
  2. Щелкнуть правой кнопкой мыши по стилю, который хотите изменить и выбрать команду Изменить.
  3. Откроется диалоговое окно Стиль, в котором указано применяемое к ячейке форматирование.
  4. Нажмите на кнопку Формат, и в появившемся диалоговом окне Формат ячеек задайте необходимое форматирование. Например, чтобы изменить размер шрифта перейдите на вкладку Шрифт, задайте нужный размер и нажмите кнопку ОК.
  5. Нажмите еще раз кнопку ОК, чтобы закрыть окно Стиль и применить форматирование к изменяемому стилю.

Перенос стилей в другую книгу

К сожалению, стили применяются к текущей книге. Т.е. если вы откроете новую книгу, то в ней будут отсутствовать новые стили, которые были ранее созданы. Чтобы повторно не создавать стили существует инструмент объединения стилей. Для этого нужно:

  1. Открыть книгу, которая уже содержит новые стили. И открыть файл, в которую нужно перенести эти стили.
  2. Перейдите к книге, которая содержит новые стили и откройте меню стилей Главная ->Стили ячеек.
  3. Выберите команду Объединить, откроется диалоговое окно Объединение стилей.
  4. В этом окне содержится перечень всех открытых книг. Выберите книгу в которую необходимо скопировать стили и нажмите кнопку OK.
Читать еще:  Как восстановить замененный файл excel

Сборник формул для условного форматирования

В данной статье собран список формул, которые можно использовать в условном форматировании ячеек, заданным при помощи формулы:

  • Excel 2003 : Формат (Format)Условное форматирование (Conditional formatting)формула;
  • Excel 2007-2010 : вкладка Главная (Home)Условное форматирование (Conditional formatting)Создать правило (New rule)Использовать формулу для определения форматируемых ячеек (Use a formula to determine which cells to format)

Подробнее об условном форматировании можно прочитать в статье: Основные понятия условного форматирования и как его создать

Все условия приведены для диапазона A1:A20 . Это означает, что для корректного выполнения условия необходимо выделить диапазон A1:A20 (столбцов может быть больше), начиная с ячейки A1 , после чего назначить условие.
Если выделять необходимо не с первой строки, а скажем, с 4-ой, то и выделить надо будет диапазон A4:A20 и в формуле для условия указывать в качестве критерия первую ячейку выделенного диапазона — A4 .

Если необходимо выделять форматированием не только конкретную ячейку, удовлетворяющую условию, а всю строку таблицы на основе ячейки одного столбца, то перед установкой правила необходимо выделить всю таблицу, строки которой необходимо форматировать, а ссылку на столбец с критерием закрепить:
= $A1 =МАКС( $A$1:$A$20 )
при выделенном диапазоне A1:F20 (диапазон применения условного форматирования), будет выделена строка A7:F7 , если в ячейке A7 будет максимальное число.

Так же можно применять не к конкретно одному столбцу, а к полностью диапазону. Но в этом случае надо знать принцип смещения ссылок в формулах, чтобы условия применялись именно к нужным ячейкам. Например, если задать условие для диапазона B1:D10 в виде формулы: = B1 A1 , то цветом будут выделены ячейки столбца B, если значение ячейки столбца А в той же строке меньше( B1, B3). При этом если ячейки столбца D меньше ячеек столбца C в той же строке — они тоже будут выделены( D1 , D5 ).

  • Выделение ячеек с числами:
    =ЕЧИСЛО( A1 )
  • Выделение ячеек с числами, но не учитывая нули:
    =И(ЕЧИСЛО( A1 ); A1 <>0)
  • Выделение строк со значением больше 0:
    = A1 >0
  • Выделение строк со значением в диапазоне от 3 до 10:
    =И( A1 >=3; A1
  • Выделение в диапазоне $A$1:$A$20 ячейки с максимальным значением:
    = A1 =МАКС( $A$1:$A$20 )
  • Выделение в диапазоне $A$1:$A$20 ячейки с минимальным значением:
    =И(ЕЧИСЛО( A1 ); A1 =МИН( $A$1:$A$20 ))
  • Выделение в диапазоне $A$1:$A$20 ячейки со вторым по величине числом. Т.е. из чисел 1,2,3,4,5,6,7 будет выделено число 6:
    = A1 =НАИБОЛЬШИЙ( $A$1:$A$20 ;2)

  • Выделение ячеек с любым текстом:
    =ЕТЕКСТ( A1 )
  • Выделение ячеек с текстом Итог:
    = A1 =»Итог»
  • Выделение ячеек, содержащих текст Итог:
    =СЧЁТЕСЛИ( A1 ;»*итог*»)
    =НЕ(ЕОШ(ПОИСК(«итог»; A1 )))
  • Выделение ячеек, не содержащих текст Итог:
    =СЧЁТЕСЛИ( A1 ;»*итог*»)=0
    =ЕОШ(ПОИСК(«итог»; A1 ))
  • Выделение ячеек, текст которых начинается со слова Итог:
    =ЛЕВСИМВ( A1 ;4)=»Итог»
  • Выделение ячеек, текст которых заканчивается на слово Итог:
    =ПРАВСИМВ( A1 ;4)=»Итог»

  • Выделение текущей даты:
    = A1 =СЕГОДНЯ()
  • Выделение ячейки с датой, больше текущей:
    = A1 >СЕГОДНЯ()
  • Выделение ячейки с датой, которая наступит через неделю:
    = A1 =СЕГОДНЯ()+7
  • Выделение ячеек с датами текущего месяца(любого года):
    =МЕСЯЦ( A1 )=МЕСЯЦ(СЕГОДНЯ())
  • Выделение ячеек с датами текущего месяца текущего года:
    =И(МЕСЯЦ( A1 )=МЕСЯЦ(СЕГОДНЯ());ГОД( A1 )=ГОД(СЕГОДНЯ()))
    или
    =ТЕКСТ( A1 ;»ГГГГММ»)=ТЕКСТ(СЕГОДНЯ();»ГГГГММ»)
  • Выделение ячеек с выходными днями:
    =ДЕНЬНЕД( A1 ;2)>5
  • Выделение ячеек с будними днями:
    =ДЕНЬНЕД( A1 ;2)
  • Выделение ячеек, входящих в указанный период(промежуток) дат:
    =И( $A1 >ДАТА(2015;9;1); $A1

  • Выделение различий в ячейках по условию:
    = A1 <> $B1
  • Выделение ячейки, если ячейка следующего столбца(B) этой же строки меньше:
    = A1 > B1
  • Выделение строк цветом через одну:
    =ОСТАТ(СТРОКА();2)
  • Выделение строк цветом, если значение ячейки столбца A присутствует в диапазоне $F$1:$H$5000 :
    =СЧЁТЕСЛИ( $F$1:$H$5000 ; A1 )
  • Выделение строк цветом, если значение ячейки столбца A отсутствует в диапазоне $F$1:$H$5000 :
    =СЧЁТЕСЛИ( $F$1:$H$5000 ; A1 )=0
  • Выделение цветом ячейки, если её значение в диапазоне A1:A20 второе по счету:
    =СЧЁТЕСЛИ( $A$1:$A1 ; A1 )=2
  • Выделение ячеек, содержащих ошибки (#ЗНАЧ!; #Н/Д; #ССЫЛКА! и т.п.). Помимо просто выявления ячеек с ошибками можно применять, когда необходимо скрыть ошибочные значения в ячейках(назначив цвет шрифта таким же, как и цвет заливки):
    =ЕОШИБКА( A )
  • Выделение непустых ячеек в столбце A :
    = $A1 <>«»
  • Статья помогла? Поделись ссылкой с друзьями!

    Ссылка на основную публикацию
    Adblock
    detector